LHD : Falling through the floor.
Closed, InvalidPublic

Description

Walk on LHD and you fall through the floor.

-Landing Deck in front of the super structure.
-Well deck near the elevator-request control pannel.

olanguedoc added a comment.EditedFeb 15 2016, 4:15 PM

If I remember correctly, it did it on the Assault version, Empty Version.
I tested this on Stratis & I had ACE 3 active

Walking & Running.

Tupolov added a comment.EditedFeb 15 2016, 4:19 PM

Need kinda exact location tbh.

in the debug console do this and exec locally:

(LHD is name of LHD object)

test = LHD worldToModel (position player)

in the watch variables area type

test

Let us know the model position that is returned (can be approxiamate, i.e. just before you fall)

I'll test it. For your Info I had 2xLHD Side by side.

TheConen assigned this task to Tupolov.Feb 18 2016, 9:13 AM
TheConen changed the task status from Needs Review to Assigned.
TheConen triaged this task as Low priority.

I placed it on Lingor and had the same bug. Across the whole ship is a line that I can't cross. I start swimming in the air and then I glitch through the ship and die. The position on the flight deck is right where the word rotors is written on the tower.

I think I found the problem. I placed it over the map border. When I place it on, or outside the map, everything workes fine.

Chairborne moved this task from Backlog to Bugs/TODO on the Vehicles board.Mar 6 2016, 2:01 PM
SpecOp0 added a subscriber: SpecOp0.EditedApr 17 2017, 5:20 PM

Edit: Bad interaction between map objects and LHD. Report can be ignored I guess...
I got this bug in version 1.9.0

[16.0645,4.09863,-4.73988]

Same happens if you are a deck below
[16.8945,3.76465,-8.15388]

Did you place it over the map border as well? Try moving it, that should fix it. ;)

Hmmm...not quite the case.
I reproduced with a wrong CUP Units version. With new CUP Units it works in an open area.

But in the mission (pictures above) I placed the LHD at a port. There is a crane and some stuff which seems to interact with the LHD in a way that you can fall through. If the LHD is moved you will fall through at different place.

I guess it is a vanilla problem. It isn't CUP or the map author or is it?

Chairborne raised the priority of this task from Low to Unbreak Now!.May 20 2017, 4:25 PM

bumping priority up, gonna take a look soon

Chairborne closed this task as Invalid.Jun 16 2017, 9:21 AM

Upon review everything seems to be in working order.
Tested on Stratis, when i put it down and roam around in the areas you pointed out i could move regularly without issues.
If you move the LHD with Zeus when the game is live i suspect that might be the cause, otherwise i cant replicate it.