L85A2 optics clipping with uniforms
Closed, ResolvedPublic

Description

If kneeling, aiming and moving forward with "CUP_optic_Elcan" equipped on L85a2´s will result in the Uniform obstructing sight.

Details

Commits
Restricted Diffusion Commit
Tzer added a subscriber: Tzer.Jun 8 2016, 9:57 PM

This is actually 2 separate problems, the new L85/86 model introduced in CUP 1.6 has the same problem as the old one did... having the right clothing/vest/backpack combination, crouching and moving while scoped in blocks the view occasionally. The problem is less common with the new model than the old one, but still happens.

However, there is another problem with both which blocks view with multiple guns
Elcan Optic "CUP_optic_Elcan"
Elcan Optic Reflex "CUP_optic_Elcan_reflex"

How to reproduce:

  1. Go in Virtual arsenal
  2. Equip clothes, armor, backpack.
  3. Choose a gun like any of MK16, CZ805, SA-58 and equip it with scopes above
  4. Go prone and deploy the gun with "c".
  5. Zoom in and observer the view being blocked by your equipment. If you strip naked it won't block the view.

I still think it has to do with the position of the optics and eye relief in general being too far back.

Chairborne raised the priority of this task from High to Unbreak Now!.Aug 19 2016, 3:55 PM

Hand animations need to be adjusted before it's ready for next patch.

The SUSAT L9A1 scope and the XM8 Compact seems to be affected by the same issue

OfotViking closed this task as Resolved by committing Restricted Diffusion Commit.Sep 13 2016, 11:10 PM
OfotViking added a commit: Restricted Diffusion Commit.