AI driving problems in Sahrani
Closed, ResolvedPublic

Description

When trying to follow roads, AI can't drive straight and does a serpentine like pattern. It only happens in CUP version, SMD A3 and A2 work fine.

Better see for yourself:

SMD Sahrani A2

SMD Sahrani A3

CUP Sahrani

seba1976 created this task.Dec 1 2016, 11:22 PM
jimbredda added a subscriber: jimbredda.EditedMay 27 2017, 6:27 AM

I can confirm this. Makes the map unplayable essentially. AI also cannot use bridges and since bridges connect several main roads on the map it further impedes the map's ability to be used.

I've got this reply from NeoArmageddon on the BI forums: "it is a problem with the roads that can only be fixed when rebuilding Sahrani from source whch is most likely not happening very soon as it takes a lot of time to setup everything correctly and build it without errors.", on February 1st, 2017.

torndeco closed this task as Resolved.Tue, Dec 5, 11:11 PM
torndeco claimed this task.
torndeco added a subscriber: torndeco.

Just tested AI driving in Jeep in same road on Sahrani, no issues.
Either fixed in recent commit changes to sara wrp or recent changes to arma itself.

If you care to test, try out the next build of Dev CUP Terrains