Zeus cannot load specific CUP Vehicles and Units due to CfgPatches being misconfigured
Closed, ResolvedPublic

Description

A significant amount of factions in the Community Upgrade project Vehicles and Units are missing at least part of their overall units and vehicles list when the mods are loaded in Zeus. This appears to be due to a misconfigured CfgPatches file for these items.

Attempting to force load the missing vehicles or units (by syncing them to a Manage Addons Zeus module) produces these results (in this case for some of the US Army MH6 helicopters):

Some objects (CUP_B_MH6M_USA, CUP_B_AH6M_AT_USA, CUP_B_AH6M_Escort_GAU_USA) are misconfigured and cannot be used by Zeus as a result.
Addon authors (Community Upgrade Project) must correctly define all objects in CfgPatches.

Steps for Reproduction:

  1. Add in a CUP vehicle (or unit) that is only visible in the ED3N Editor, and not the Zeus editor.
  2. Sync that vehicle to a Manage Addons module, with its owner being a Zeus module that is assigned to a player or Zeus virtual entity.
  3. Attempt to load the mission either in ED3N Editor, singleplayer, or multiplayer. An exception / error box will appear at the bottom of the screen once loaded.

Details

Commits
Restricted Diffusion Commit
Affected classnames
CUP_B_MH6M_USA, CUP_B_AH6M_AT_USA, CUP_B_AH6M_Escort_GAU_USA, more

Related Objects

Is this with just CUP loaded?
I haven't messed with Zeus in a while but i remember most vehicles were showing up correctly.

Jonathan_Fort added a comment.EditedJun 8 2017, 6:30 PM

It appears the issue persists regardless of if third-party mods are loaded or if CUP and its dependencies are the only mods loaded.

Jonathan_Fort added a comment.EditedJun 8 2017, 6:38 PM

Update from further testing on our end: it appears that Zeus can be made aware the object exists using the Add Editable Objects module if it already exists in the mission, but any attempt to manipulate it results in the action failing and either the vehicle rubber-banding back to the location it was at before Zeus attempted editing, or nothing at all happening. Even with the Zeus module being made aware than an object of that type physically exists in-mission, Zeus is still unable to spawn additional instances of the vehicle or unit.

T1992: AH-1Z Missing From Zeus Editor may be an already-closed, but related issue.

That's odd, they show up fine in the editor when playing as Zeus (contrary to T1992 where the super cobra would just not show period), gonna check what happens on local hosted game.

Even in a vanilla zeus scenario things are working fine here. Notice that some AH6 variants are being removed because the dynamic loadout editor is being added, but objects show fine otherwise.
Are you sure modded content is enabled in the Zeus module?

Edit: now that i check i see some ground units are missing from factions like usmc and bundeswehr, probably thats what also causing stuff disappearing from Zeus.

Chairborne closed this task as Resolved by committing Restricted Diffusion Commit.Sep 26 2017, 5:08 PM
Chairborne added a commit: Restricted Diffusion Commit.

It should be resolved now, if you still find missing entries let us know.