LHD Heli marker goes on the ground
Closed, ResolvedPublic

Description

Hi

So, when you place a LHD, the heli marker are above it, on the sea ground.

Please see here : http://imgur.com/a/6lDWE

Details

Commits
Restricted Diffusion Commit
Affected classnames
CUP_B_LHD_*
Oshydaka created this task.Feb 8 2016, 7:00 PM
Oshydaka renamed this task from LHD Heli Mark goes on the ground to LHD Heli marker goes on the ground.
Tupolov claimed this task.Feb 8 2016, 8:17 PM
Tupolov reassigned this task from Tupolov to Oshydaka.Feb 8 2016, 8:28 PM
Tupolov added a subscriber: Tupolov.

We don't place any heli markers on the LHD. Can you provide the exact steps for what you are trying to do?

I've just placed a few LHD, and i fell in the water. Then, i've seen something weird under the LHD on the sea ground.

So i've used the ArmA Camera in the editor to have a clear view and i notice some "H" marker on the sea ground.

Check the attached imgur album http://imgur.com/a/6lDWE

The first one is on Altis, the 2 others are on Chernarus.

NeoArmageddon reassigned this task from Oshydaka to Tupolov.Feb 9 2016, 8:38 AM
Tupolov reassigned this task from Tupolov to Oshydaka.Feb 9 2016, 8:53 AM

We don't place these markers, so i have no idea what is creating these. i cannot reproduce this issue.

Please test with CBA and CUP only.

Hello

So, i was not sure if i got only CBA & CUP last time, so i make sure of this now

Please see here :

http://imgur.com/a/smvQb

Img 1 is my activated mods.
Img 2 is the LHD on the main airport ground, we can see heli markers
Img 3 same place, without the LHD, no markers
Img 4 LHD on water, we can see markers on the ground
Img 5 same place, with no LHD, no markers

Thanks for testing that!

Can you test without CUP Terrains?

Cheers

Hello

So i test without CUP Terrains, and i don't see those heli pads markers

http://imgur.com/a/n4auq

Good call ^^

i investagate a little more.

With CUP terrain activated, i can do this : http://i.imgur.com/B2oS4SJ.jpg

And the marker appear.

Without CUP terrain, the marker doesn't appear.

I think it has to do in fnc_initShip.sqf (\CUP\WaterVehicles\CUP_WaterVehicles_Core\functions)

        // Create heli pads
	_heliPads = getArray (configFile >> "CfgVehicles" >> typeOf _ship >> "heliPads");
	{
		private ["_helipad"];
		_helipad = "HeliH" createVehicle [0,0,0];
		_helipad attachTo [_ship, [0,0,0], _x];
	} foreach _heliPads;

Hmm, it looks like CUP Terrains might overwrite the HeliH class. I need to check that when I have some time, but that won't be before next month.

Tupolov closed this task as Resolved by committing Restricted Diffusion Commit.Feb 15 2016, 9:09 PM
Tupolov added a commit: Restricted Diffusion Commit.

I switched the LHD to use Land_HelipadEmpty_F instead