C-130J falls from sky
Closed, ResolvedPublic

Description

When placing C-130J in 2D editor, and selecting SPECIAL > FLYING, plane flies normal.

When placing the same plane using the EDEN editor and selection transform> move to flight altitude, plane crashes, doesn't fly, drops to the ground. (I don't see the SPECIAL >FLYING option, as you do in the old 2d Editor)

Doesn't happen with C-130's created by other authors (Sabre).

Doesn't happen with other CUP planes:

mtklip created this task.Mar 1 2016, 4:04 PM

Just a couple more notes.

If I'm the pilot for the C130, and start in the air, I get the same problem, can't move, but, don't crash.

However, if I start from the ground, plane takes off and flies normal.

It's the roadway lod (the magic model voodoo that allows you to walk inside vehicles) that causes this.
Proof of this is that the mi6a has the same issue, while the mi6t (that doesn't have roadway lod) is spawned correctly.

mtklip added a comment.Mar 3 2016, 1:43 PM

This only happens with the EDEN editor. You'd think that Bohemia will have the same problem with their models if they are looking to have the same 'walk in vehicle' capability for their planes. Unless they solved it some other way. Good to know, thanks.

I ran into this when I was muck'n around with a paradrop scenario. I'm a small time Arma user, long time VBS2/VBS3 abuser.

good luck in your CUP endeavors, your community efforts are much appreciated.

I'm hopeful for the expansion since they teased fast attack vehicles and a gargantuan VTOL plane.
In theory we wouldn't even need roadway lods since vehicles use geometry lods for collisions but it feels weird that you can drive but not walk on something.

mtklip added a comment.Mar 3 2016, 1:49 PM

PS.

Low priority for me.

Just an observation.

But, might be critical for a serious scenario maker wanting to use that vehicle to start in flight (without having to do an external script, if that was possible)

Chairborne moved this task from Backlog to Bugs/TODO on the Vehicles board.Mar 6 2016, 2:01 PM
Chairborne closed this task as Resolved.Oct 6 2017, 5:14 PM
Chairborne claimed this task.

This was caused by the roadway LOD and arma being weird, this has since been resolved.