ZU-23 Static wont rearm right
Closed, ResolvedPublic

Description

When the ZU-23 static rearms it wont return ammo to you until it is unmanned and remand. If a unit stays in the ZU-23 it will never rearm its missing magazines and will remain empty

Details

Affected classnames
ZU_23 Static
Apollo created this task.Jul 26 2016, 9:44 AM
Sparfell_19 changed the task status from Needs Review to Open.Oct 14 2016, 1:31 PM
Sparfell_19 triaged this task as Normal priority.
Sparfell_19 added a subscriber: Sparfell_19.

I cannot reproduce.
Could you provide more informations, do you mean rearm with an ammo truck ?

Apollo added a comment.EditedOct 14 2016, 5:44 PM

I cannot reproduce.
Could you provide more informations, do you mean rearm with an ammo truck ?

Yes with ammo truck. but i have not checked it since my OP

I think the problem is more likely with the rearm truck rather than the Zu-23. I've had problems too using vanilla rearm functionality with the Urals and T-55/T-72.

Agreed. Seems to be an ammo truck issue.

Maybe related to supplyradius config entry.

I improved supplyradius. Now it rearms but only one magazine (only tested with ZU-23). I don't know if it's a normal behaviour.

I think that depends on the amount of supplies the truck has.
Don't remember which config entry controls that though.
Checking the vanilla resupply trucks should be explicative.

The truck has enough amount of supplies. It can rearm ZU-23 several times but only one mag at a time.
Anyway, I didn't look into it enough yet.

I check this and this issue has been solved

NeoArmageddon closed this task as Resolved.Apr 22 2018, 7:34 AM