VTOL aircraft not working as VTOL
Open, NormalPublic

Description

The F-35 and the harrier have a bug that the only way to engage the VTOL mode is to start with a normal takeoff before the vectoring works properly. done exactly as it asks but still requires the vehicle to move forward first.

Details

Commits
Restricted Diffusion Commit

Harrier is not VTOL by design so nothing weird there, will look into the F-35.

jonpas added a subscriber: jonpas.Oct 2 2017, 2:45 PM

We were looking into this last week. The solution is to move them to "airplanex" simulation (PhysX) instead of "airplane" (old BI physics). Then vectoring modes work as intended. BI was also notified they don't work properly in old physics engine. Changing it to "airplanex" is not an easy job though, we ran into a problem of wheel brakes not working at all and couldn't figure it out yet.

Chairborne changed the task status from Needs Review to Acknowledged.Dec 9 2018, 12:42 PM
Freddo3000 added a commit: Restricted Diffusion Commit.Mar 10 2020, 7:38 PM
Freddo3000 closed this task as Resolved.
Freddo3000 reopened this task as Open.Mar 10 2020, 8:06 PM
Freddo3000 added a subscriber: Freddo3000.

Scratch that, problem is still present.

Freddo3000 triaged this task as Normal priority.Mar 11 2020, 11:35 AM