AT Missiles no longer selectable
Closed, ResolvedPublic

Description

Prior to TANK DLC, one clicked "NEXT WEAPON" hot key to cycle weapon systems on an aircraft. It still does that, but AT missiles (VIKR on KA, and others) do not cycle or show. They're clearly mounted on rails and are on the aircraft but they don't cycle. Not sure if it's a new key now or if there's a different way to access AT missiles. ALWARREN confirmed my observation and asked me to submit a ticket.

It makes CUP aircraft almost worthless now. :(

Just guessing here, but it may have something to do with the new top down system vanilla AT missiles have

1.82 added

class missiles_SCALPEL: RocketPods {
    modes[] = {"TopDown"};
    class TopDown: RocketPods {

and CUP_Vmlauncher_AT16_veh: Missiles_Scalpel

seems to work by just adding
modes[]= {"this"}; to config

Extra info from Da12thMonkey:

da12thMonkey - Today at 8:54 AM
AFAIK it happens when the missiles have mismatches of the flightprofiles[] parameters in the ammo config and the modes[] in the launcher
since the new flight profiles for topDown attack and loalAltitude etc. require fire modes that match instead of using just modes[]=["this"];(edited)
da12thMonkey - Today at 9:00 AM
adding the above to the weapon and adding 
class Direct {};
flightProfiles=[Direct];
 to the ammo class gets rid of all the new stuff that might inherit

Can confirm PabstMirror's fix works.

Superxpdude triaged this task as Unbreak Now! priority.
Alwarren closed this task as Resolved.Apr 18 2018, 9:41 PM
Alwarren claimed this task.