Since Tanks, game crash
Closed, InvalidPublic

Description

Hi,
Since Tank DLC came out, i experience various crash, more frequently in 64 bit, but happen also in 32 bit.

After a while, searching different angle to solution this (redl addons, uninstall arma3 and re-dl it through steam, check my memory (windows memory and memtest, using only one of my ram(s) slot, swaping them around, perform a crystal dicks on my SSDs), trying all différent launcher option (64 bit, 32 bit, different malloc, windowed, different profiles, ...)) I ending up to think that the add on cause my game to crash.

So today i created a very simple mission, from arma 3 wanilla with no mod : on Altis i add an blufor officer, attach Zeus module to it.

Then in 64 bit :

  • on vanilla, play the mission, go to Zeus, create a lot of vanilla tank (Copy paste tank platoons several time) until i fulfill my memory : game is very lag (as expected) but don't crash.
  • Then I downloaded all 3 CUP addons from workshop, launch arma 3 with those mod, play my mission, and as Zeus I add a lot of M60E3 from the mod then the game end up crashing every time (mainly within the first minute).
  • Maybe you don't care, but I tested also with RHSAFRF addon and launch arma 3 with this mod, play my mission, and as Zeus I add a lot of different armored vehicules (T-72 mod 1984 platton) and the game crash also.

Step to reproduce :

0) launch the game with only CUP addon (vehicule, weapon and Unit)

  1. Use my simple mission, or create it as described
  2. in the mission toggle to Zeus ([Y])
  3. Add a tank M60E3
  4. select it, and start to spam Ctrl-C / Ctrl-V around to pop a lot of tanks, when you ahve 50-100+ tanks you can try make enemy tank too.
  5. wait
  6. Crash to Desktop

The reason i use this procedure is to make it crash sooner, but in real mission using addon i crash also but latter (5 minute to 1hour latter).

Elia created this task.Apr 20 2018, 5:44 PM
NeoArmageddon closed this task as Invalid.EditedApr 20 2018, 11:35 PM
NeoArmageddon claimed this task.
NeoArmageddon added a subscriber: NeoArmageddon.

It can be expected that the game crashes with many vehicles spawned and Arma starting to access pagefile etc. You most likely experience this only with other mods loaded, as those are loaded additionally by the game and thus producing a larger memory footprint of the game.

Also, as you said, it is the same with RHS, which highly implies your crashes are a problem with A3 itself and not our mod, so there is nothing we can do about it. I will close this as invalid until there is proof that this is a fixable bug with CUP tanks (for example by reproducing a crash with a single tank in a mission without anything else and crosscheking with vanilla tanks).

Elia added a comment.Apr 21 2018, 1:31 PM

Well as i said earlier :

The reason i use this procedure is to make it crash sooner, but in real mission using addon i crash also but latter (5 minute to 1hour latter).

So yeah i crash with addon (CUP, RHS or IFA3) since Tank DLC came out, even with few tanks, it just take longer to crash than in my stresstest mission where i spawn plenty of tanks.

Elia added a comment.Apr 21 2018, 1:32 PM

If you want here is my original ARMA 3 tracker : https://feedback.bistudio.com/T128171

Tried it and I cannot reproduce it, neither any lag nor crash.

Elia added a comment.Apr 22 2018, 12:25 AM

Yeah It seems to afflict me only ... don't know why, my teammate don't have any issue. Just me since Tank DLC ...

Have seen something similar before. You might want to check your computers RAM with, for example memtest+ or something similar. It might be a hardware problem (althou it could be a software issue with OS, Arma or thirdparty programs aswell).

This comment was removed by NeoArmageddon.
Elia added a comment.Apr 22 2018, 8:05 PM

Yeah did memtest86, windows memry check too, no error found. Swaping my pair of 4GB RAM (I have 2*4GB DDR3) to test only one of them at a time, but I still crash with one or the other.
I don't think it is a hardware issue, because on my test with popping lot of vanilla tank the game is very slow laggy but don't crash (until I get Out Of Memory error, witch is normal cause i'm limited by my ram + virtual memory).

What you say, though, does not point at a problem with CUP. If you get lag with vanilla tanks and out of memory, that might be amplified by loaded addons. It still points at an issue with either Arma 3 itself, or your installation.

Elia added a comment.Apr 23 2018, 4:45 PM

Lag and Out of memory are totally normal ! the way i perform my stress test cause this and this is NOT what i complain about.

I complain because on my teammate made missions (we play around 3 mission per week, all created by our clan) I crash soon or later (sometime within 5 minute after briefing, sometime 30 minute after, it vary a lot). So for testing only , I created my simple Zeus mission where i spawn lot of tank in order to reproduce the crash as soon as possible.

And what i observed with my Zeus mission is that I crash (ARMA3 has stopped worked) when i spawn addon tanks (spawn a lot for crashing asap) and i don't crash when spawning vanilla tank (spawn a lot to to make it crash asap). Since i don't crash with vanilla tank i just mentioned for the record that I end up having a totally expected out of memory error, but notARMA3 has stopped worked crash.

As for my installation, I uninstalled arma 3 totally (including arma3 folders) and re downloaded it via steam for a fresh install. Downloaded the mod via steam Workshop to be sure to have correct files.

I know what you are complaining about, but I cannot reproduce your problem, and I tried to. I don't even get the lag or out of memory errors that you get. All I am saying is that all points at a problem on your end, and that it has nothing to do with CUP.