Static Artillery Unable To Aim Up / Down
Closed, ResolvedPublic

Description

Both versions of the D-30 as well as the M119 are unable to elevate or depress the gun. Sideways traverse works fine.

Details

Commits
Restricted Diffusion Commit
Affected classnames
CUP_O_D30_AT_RU CUP_O_D30_RU CUP_B_M119_US

Related Objects

Eogos added a subscriber: Eogos.Aug 31 2018, 7:58 PM

This isn't an issue, that's how it is designed. You have to use page up/down to manually do elevation otherwise you're supposed to use the artillery computer.

Cyruz added a subscriber: Cyruz.Aug 31 2018, 7:58 PM

@Eogos can the AI do that?

Arty guns are not meant to be used for direct fire by AI i think. Also elevation is controlled with page up/down.

Eogos added a comment.Aug 31 2018, 8:15 PM

@Cyruz @Chairborne correct, AI are not able to use any artillery as direct fire. That is why there is an "AT" version of the D-30.

Eogos added a comment.Aug 31 2018, 8:18 PM

However, as I say that I realize he said the AT version also is unable to elevate or depress. I'll go do some testing real quick.

Eogos added a comment.EditedAug 31 2018, 8:26 PM

Alright I can confirm the D-30 Artillery version and the M119 are working as intended however the D-30 AT version has, for some reason, started acting like the artillery version but without an artillery computer. Maybe a fuck up from when the D-30 recoil was getting fixed? Maybe someone copied a part of a config over that they shouldn't have?

@dancemoox in the meantime use page up/down if you absolutely need to use the D-30 AT variant. If you need AI to use it well then idk just wait for a patch I guess.

Eogos added a comment.Aug 31 2018, 8:46 PM

On a semi related note: the get in action for the D30s and the M119 are in really shitty spots. For the D-30s you basically have to hug one side of the gun shield and for the M119 you have to hug one of the tires. It'd benefit from moving that action more towards the breach of the guns and widening the area you have to be in to get the action so you don't have to be giving the gun a reach around for it to pop up.

Freddo3000 closed this task as Wontfix.Jan 3 2020, 1:12 AM
Chairborne reopened this task as Acknowledged.Jan 3 2020, 1:30 AM
Chairborne claimed this task.

the AT gun could probably use improvements, i use static weapons so little i hardly ever notice them not working right

Freddo3000 changed the task status from Acknowledged to Open.Jan 3 2020, 2:48 AM
Freddo3000 changed the task status from Open to Acknowledged.
Freddo3000 triaged this task as Low priority.
Urban closed this task as Resolved by committing Restricted Diffusion Commit.Jun 29 2020, 4:12 PM
Urban added a commit: Restricted Diffusion Commit.