Javelin seems very weak
Closed, ResolvedPublic

Description

Just from a quick check in the editor, I put 5 missiles in to the T-72 and it's showing 0.6 damage in the console, getting in to the vehicle shows all systems as undamaged.

Also fired a few missiles at a T-34 and it didn't seem to take any serious damage. Titan killed the T-34 in two hits (still seems excessive!).

I'd expect this old Russian armour to be killed in one hit. There is this footage on youtube of them training with the Jav and it seems pretty effective. https://www.youtube.com/watch?v=Wffv5NCrrvc

Details

Affected classnames
CUP_launch_Javelin
Cyruz created this task.Sep 16 2018, 2:33 PM

DId you try this on the development version, or the currently released one ?

Cyruz added a comment.Sep 16 2018, 2:51 PM

Dev build, but missed last weeks one. Tried it without ACE loaded since they do their own lock-on system but can't for the life of me figure out how it locks in vanilla...

Motor must be running, I think, to lock the Javelin (since it's heat).

Also, I noticed problems with tanks becoming indestructible with ACE, not only CUP, but Vanilla too.

Cyruz added a comment.Sep 16 2018, 6:38 PM

Yeah ace cookoff has weird bugs. It's disabled by default in ACE currently due to said issue.

I'll recheck vanilla but unless it's a flight profile issue it shouldn't impact damage or penetration.

Cyruz added a comment.Sep 16 2018, 7:13 PM

Knew when I said the above I was cursing myself. Works fine in vanilla. Assume the missile flight path hitting it from the top is missing key components or something odd. Is there anything done in the ACE compats for the Javelin?

Urban added a subscriber: Urban.May 26 2019, 6:59 PM

Javelin damage is almost same as vanilla Titan. Regard ACE Titan it has 1400 damage + 585 submunition damage (which instakill everything) comparing to vanilla 95 damage + 585 submunition damage (I think ACE is a bit overkill). This ticket will closed after next update.

Urban moved this task from Backlog to Pending Beta Test on the Weapons board.May 26 2019, 7:00 PM
Goopy added a subscriber: Goopy.May 26 2019, 7:40 PM

Realistically the Javelin should have an even greater damage value than the Titan, since that system is the Mini-Spike (which is a less capable man portable version of the regular Spike missile, of which has a penetration value of above 700mm of armor). Although from what I've seen the Javelin currently deals with most armor in one or two shots, the only real issue with it was the unrealistically low range that prevented AI or players from really using it to it's full potential. Although that's been fixed recently in the dev build.

I noticed that too. Direct hit on a T-72 or T-90 just damages it whereas a top attack will kill it outright.

Tried it just now with a T-90 and a T-72:

  • Front
  • Rear
  • Top Down
  • Direct Attack

In all cases, the javelin immediately annihilated the tank.
Can someone tell me how to reproduce this problem?

I think it's only with ACE loaded and that does stuff to the missile guidance

@Cyruz Is it a general ACE issue, or with our ACE Compatibility ?

Cyruz added a comment.EditedOct 13 2019, 12:20 PM

This is the flight path from the ACE top down, referred to in the configs as "JAV_TOP" it seems to come in at an angle which means it doesn't kill on the first hit. It took 2 shots each time I tested it in top down mode. Direct fire killed it instantly each time.

This is the flight path from vanilla top down, kills in one hit each time.

"JAV_TOP" is defined in core ACE files - https://github.com/acemod/ACE3/blob/e5a15d200f44df5fccc0bc5575d18d80b35538dd/addons/missileguidance/ACE_GuidanceConfig.hpp

Goopy added a comment.EditedOct 13 2019, 11:36 PM

@Alwarren Since this ticket was posted the Javelin's damage properties were fixed by @Urban (https://dev.cup-arma3.org/rWEAPONSSVN1060), so I don't think the Javelin's low damage is an issue anymore. So this could be closed as resolved.

Alwarren closed this task as Resolved.Oct 13 2019, 11:38 PM
Alwarren claimed this task.

That's why I asked, to make sure the issue is resolved