"Cannot Edit/Play this mission; it is dependent on downloadable content that has been deleted.cup_buildings_data"
Closed, InvalidPublic

Description

I am having a problem when trying to play the "Dynamic Universal War System Overhauled v1.19". Whenever I die and try to load a save I get this error message, and I am forced to completely restart the progress of the mission.

Note that I already tried to "unsubscribe" and then subscribe again to the CUP Terrains, maps, core, etc. from the steam, and it did not work.

Please, IF this is a problem with the mission, keep this bug report open so that the person that made this version of the mission can assist me.

If DxDiag is necessary please let me know.

Details

Affected classnames
cup_buildings_data

what terrain is that on? some third party terrains do cause errors with missing addons like this from time to time.

This SPECIFIC occurrence was on the "Area 51 Groom Lake" https://steamcommunity.com/sharedfiles/filedetails/?id=1419493125&searchtext=

But I had it happen on me in the default map (Altis) from the ORIGINAL DUWS mission. To me this makes it seem like a problem with CUP. MAYBE it is not providing me with this cup_buildings_data file, then it breaks my saves.

NeoArmageddon closed this task as Invalid.
NeoArmageddon added a subscriber: NeoArmageddon.

The case that this happens on vanilla terrains like Altis strongly suggests, that the problem is caused by missing addon references in the mission.sqm by the mission maker. Maybe he removed them or they are somehow resolved incorrectly.

Nevertheless I am confident that this is caused by the mission and not by CUP (in the later case you would see the message at mission start or even gamestart/main menu).

I close this for now.

Well, something that I decided to give a go was to:

search of "buildings_data" in the CUP TERRAINS folder. This showed me 2 files with names very similar to the missing file on the error thing.

Then I copied these files, and renamed the cup_terrains_buildings.pbo. cup_terrains_maps-1.4.2BSIGN, and I also made a copy of the cup_terrains_buildings.pbo and renamed it to cup_terrains_buildings_data.pbo just to make sure that my POSSIBLE FIX MIGHT work.

The files that I found in the search:

LuizBarros99 added a comment.EditedOct 16 2018, 3:51 PM

The case that this happens on vanilla terrains like Altis strongly suggests, that the problem is caused by missing addon references in the mission.sqm by the mission maker. Maybe he removed them or they are somehow resolved incorrectly.

Nevertheless I am confident that this is caused by the mission and not by CUP (in the later case you would see the message at mission start or even gamestart/main menu).

I close this for now.

Oh, ok.

I guess that now I will have to talk directly to the mission creators...

changing pbo name like that won't do anything, the addon requirement is fulfilled if a pbo whose cfgpatches class with the correct name is loaded (which is something inside the config files).
this dependancy is most likely spawned by some custom terrain you have loaded, the australia map was known to cause such an error for example, there's probably more around.

@NeoArmageddon, I think that I forgot to show something. This MIGHT not be related, but MIGHT be:

I get this error every time I launch ArmA 3, but with ONLY "C.U.P. mods" selected to load this does not appear.

changing pbo name like that won't do anything, the addon requirement is fulfilled if a pbo whose cfgpatches class with the correct name is loaded (which is something inside the config files).
this dependancy is most likely spawned by some custom terrain you have loaded, the australia map was known to cause such an error for example, there's probably more around.

Oh, thanks. Well I was already basically looking through my mods, trying to find out which of them was causing the problem. This only motivated me more.