T-72M4CZ can go about 156 km/h via turning
Open, NormalPublic

Description

The T-72M4CZ has a bug that I've actually seen once before in the Iron Front mod with one of their Sherman's though not as severely.

If you get it up to max speed, including boost, and then begin turning it won't drift out of control or flip over, it'll simply just keep going and gaining speed slowly until reaching the 156 km/h mark where it seems to stop. By carefully alternating between left and right, you can somewhat go 130-150 km/h in a (somewhat) straight line.

Details

Affected classnames
CUP_B_T72_CZ
Eogos created this task.Dec 8 2018, 7:05 AM
Eogos changed the task status from Needs Review to Acknowledged.
Eogos triaged this task as Normal priority.
Eogos changed the task status from Acknowledged to Open.Dec 8 2018, 7:10 AM

isn't this an engine issue? not sure we can fix it 🤔

Eogos added a comment.Dec 8 2018, 6:21 PM

@Chairborne Fairly certain Iron Front managed to fix the Sherman that had this issue, so idk

happens with the normal T-72 as well

Eogos added a comment.Dec 9 2018, 2:09 PM

happens with the normal T-72 as well

It doesn't, I tested that before I made this ticket. I can go record a video if you wish.

it does, i just tested it, it goes up to some 100kph

try pressing A and D repeatedly very fast and you'll see the speed goes up there too. not really sure why you have a hard time believing me lol. why would i report something that isn't there?

Eogos added a comment.EditedDec 9 2018, 2:37 PM

@Chairborne Not saying you're lying, was just trying to make sure we are on the same page and not having drastically different results doing the same thing. Now I see the issue, yes you can accomplish it with the T-72 as well but by specifically trying to do it with a and d mashing. The T-72M4 does it just by normal turning with boost on, it won't ever spin out like the T-72 and T-90A do in my video.

Eogos added a comment.Dec 9 2018, 2:39 PM

Of course now that I say that, I have a feeling this may be because the T-72M4 might not have been upgraded to Tanks DLC PhysX yet... I don't remember ever seeing any commits about updating it.

anyway on vanilla tanks thats not happening so it is most likely something wrong on our end

On a possibly related note, letting go of W will leave the tank cruising decelerating extremely slowly once around 20 km/h. In addition to this, the tracks appear to be shifting weirdly back and forth.