Addon 'CUP_Afghan_Data' requires addon 'CA_E'
Closed, InvalidPublic

Description

So, I own an Arma 3 server from Host Havoc. Right now, CUP - Terrains is giving me a really hard time out of no where. In my server log it is saying that Addon 'CUP_Afghan_Data' requires addon 'CA_E'. I currently have no idea how to fix this issue and my server and its members are suffering because of it.

Details

Branch
Release/Stable

What addons are you loading? CUP Terrains - Core and CUP Terrains - Maps?

SSgt_Adams added a comment.EditedJan 3 2019, 10:49 PM

@ace;@ACE_RAG;@ACE_USAF;@ACE_AFRF;@ACE_GREF;@CBA_A3;@RHSUSAF;@RHSAFRF;@RHSGREF;@RHSSAF;@CUP_Core;@CUP_CWA;@CUP_Maps;@GRAD_Trenches;@Project_OPFOR;@task_force_radio;@Zombies;@Chernarus_Redux
(Comes from command line)

This comment was removed by SSgt_Adams.
audiocustoms closed this task as Invalid.Jan 3 2019, 11:08 PM
audiocustoms claimed this task.
audiocustoms added a subscriber: audiocustoms.
  1. The modstring for reporting CUP bugs has to be

@CBA_A3;@CUP_Core;@CUP_Maps;@CUP_CWA
nothing else

  1. The error "Addon 'CUP_Afghan_Data' requires addon 'CA_E'" is related to a corrupted download of CUP Core. Only way to fix this is to redownload the CUP Core mod. Steam has a dendency to corrupt large downloads, nothing we can do.
fnadde42 added a subscriber: fnadde42.EditedMar 28 2019, 6:43 AM

@SSgt_Adams I have an ArmA server on HostHavoc and I get the same error message as well. I have used several different methods to upload the CUP Terrain - Core mod to the server but the server get the same error message. I doubt that the file got corrupted every time but it's hard to know when there are no way of checking with a checksum on the server-side. The CUP Terrain - Core directory I copied to the server via FTP worked great on my local server.

I also tried following this instruction which told me to do the following but no dice.

addons[]=
{
	"A3_Characters_F",
	"CA_E" //<-- Add this to mission.sqm
};

Seems like whatever I do, even specify a nonexistent mission in my server config which should create an error, happens after the loading of CUP Terrain - Core and this error. I am currently troubleshooting this with HostHavoc.

EDIT: I'm only running @CUP_Core;@CUP_Maps

Make sure that the version you try to upload to your server is fine. I suspect the copy you downloaded and now try to upload is faulty.

fnadde42 added a comment.EditedMar 28 2019, 6:59 AM

I started a local server with my local copy and the same mission and it worked just fine. That should probably mean that it works, right? Do you have checksums for the files so I can verify their integrity?

EDIT: I have uploaded that local copy, God knows how many times. I've also downloaded a new copy from the CUP website and uploaded that.

If i remember correctly there should be a file in the mods main folder.

There appears to be some corruption in two files in the CUP Terrain - Core:

Checksums in my local mod (fetched by Steam):

809f20188e394744621bbe89c4db0f546d582d15 *Addons/cup_terrains_roadfix.pbo
e3cdb31120e4ea3148e1aba65929cbcf2157a70a *Addons/cup_terrains_roadfix.pbo.cup_terrains_core-1.11.2.bisign

They should be:

306330054703e86268c0e94dfd95f1bddc2c116d *Addons/cup_terrains_roadfix.pbo
b3a53eeaa1d7034304aefbdffbe630ce44192aed *Addons/cup_terrains_roadfix.pbo.cup_terrains_core-1.11.2.bisign

Gonna download the mod via another source and replace those damaged files.


I have a hard time believing that that is the cause of the problem. Here are the different ways I uploaded the mod to the server (all of them failed):

  1. Uploaded my local mod (which appears to be broken)
  2. Downloaded the mod from Armaholic and uploaded that
  3. Used HostHavocs built in Mod Manager and downloaded the mod to the server.

The chance of all of these failing must be really low. One would think at least Steam would do some error checking and retries until all files are solid but I guess billions of dollars doesn't mean the IT-infrastructure is any good.

As mentioned, steam tends to screw large mods. The safest source for downloads is from our drives/torrents. See our download page on the website for the links.

  1. Downloaded via torrent CUP Terrains - Core 1.11.2
  2. Verified their integrity
  3. Uploaded and overwrote the two corrupt files
  4. Ran server and got this message: Warning Message: Addon 'CUP_Editor_Plants_Config' requires addon 'CUP_CA_Plants_PMC'

Jesus Christ Steam... Downloaded the mod directory that was up on the server and 5 files (!!!) were corrupted. More like Steam-ing pile of shit.

Addons/cup_terrains_ca_plants_pmc.pbo: FAILED
Addons/cup_terrains_ca_buildings2.pbo: FAILED
Addons/cup_terrains_ca_language.pbo.cup_terrains_core-1.11.2.bisign: FAILED
Addons/cup_terrains_roadfix.pbo: FAILED
Addons/cup_terrains_roadfix.pbo.cup_terrains_core-1.11.2.bisign: FAILED

Uploading the torrent to the server which was fine according to the SHA1-sum. Let's see what happens.

fnadde42 added a comment.EditedMar 28 2019, 9:07 PM

Solution: Validate your files!

We have got our server working again ( @SSgt_Adams might be interested in this ) by downloading the mod via Torrent, validating that everything was fine and then re-upload all the files. Turns out that corruption of files was a much bigger problem than I thought. Naughty-naughty-Steam must fix this.

How to check if the files are valid

  1. Download Git Bash or a program like HashCheck
  2. Go to the mod directory
  3. Verify against the sums.sha1-file that contains the correct hashes. In Bash it would be: sha1sum -c sums.sha1.
  4. Program will print out if any files are corrupt and which ones.
  5. Download files again and replace them. Use direct download from mod site or Torrent since it's more likely not to be corrupted.
  6. Go to step 3 and repeat until there is no file corruption.

Nothing we as CUP can do about this, sadly... I suspect the data compression steam uses to store and transmit mods can't handle sizes like we have. Glad it worked out for you in the end.

fnadde42 added a comment.EditedMar 29 2019, 10:44 AM

Checking the integrity of the files seems to be the first thing one should do before troubleshooting further. Maybe CUP could, alongside the sum.sha1-file place a Batch/bash-script that is easy to execute and verify integrity. A script that popps up a terminal window and just showing the process. There are basic checksum-validation tools like this one that could be downloaded and executed per user request: https://sourceforge.net/projects/mute-net/files/sha1sum/Command%20Line%20Tool/

Checking file integrity should be built into ArmA itself but a close second is if the user can easily do it.