Sidechat problem
Closed, InvalidPublic

Description

Hello. I have a problem with making missions. I am using “CUP Terrains - Maps” and “CUP Terrains - Core” mods. Both are latest versions.
I tried to make a mission with a trigger that causes your character to say something like “mission complete” using sideChat. It must happen when character enters the trigger zone (or the trigger area).
But when I did it, nothing happened. Then I tried to delete all of the CUP mods and it worked. I also tried to install only the “CUP Terrains - Core” mod, and it also worked. So my suggestion is that the problem that causes sideChat not to work correctly is in the “CUP Terrains - Maps” mod. Sorry if I am mistaking.
That’s all for now. Sorry for my bad English.

Details

Branch
Release/Stable
Reproducable without other mods?
Yes
Steve created this task.Jan 4 2019, 12:55 PM
hvymtal added a subscriber: hvymtal.Jan 4 2019, 1:30 PM

What specific commands on which map? Attempting to reproduce

Steve added a comment.Jan 4 2019, 2:09 PM

What specific commands on which map? Attempting to reproduce

Thank you for your reply. The map is “Chernarus Autumn”. The commads are:
Trigger A:
Type: none
Activation: BLUFOR
Acrivation Type: Present
Condition: this
On Activation: X = true
Trigger B:
Type: none
Activation: none
Acrivation Type: —
Condition: X
On Activation: player sideChat “message”

This should be working (like I said, I tried to uninstall all of the CUP mods and it worked). But nothing happens there.

Dusin added a subscriber: Dusin.Jan 4 2019, 2:13 PM

Please, provide full mod list you are using and specify is mission launched in singleplayer or multiplayer. Thanks!

Steve added a comment.EditedJan 4 2019, 2:17 PM
In T2878#40098, @Dusin wrote:

Please, provide full mod list you are using and specify is mission launched in singleplayer or multiplayer. Thanks!

Thank you Dusin. I am using only two of the CUP mods:

  1. “CUP Terrains - Core”
  2. “CUP Terrains - Maps”

The mission is launched in singleplayer (I also tried to launch it in multiplayer but the result was the same - nothing happened).

Dusin added a comment.Jan 4 2019, 2:23 PM

Short test from me - open Startis in editor, place unit, run mission and run "sideChat" from console at mission start, at time+70 and at time+200.

A) No mods; SP -- sidechat displayed 3 times
B) CUP Terrain Core, CUP Terrain Maps; SP -- sidechat displayed 3 times
C) No mods; MP -- sidechat is not displayed
D) CUP Terrain Core, CUP Terrain Maps; MP -- sidechat is not displayed

DEV: Unable to reproduce on CUP Dev Branch using only "DEV CUP Terrains Complete". Setup was exactly as specified (BLUFOR - Present - this - X=True, X - player sideChat "message"), with the additional caveat of a 10mx10m area on Trigger 1

Live: Unable to reproduce on live using only Terrains Core and Maps. Same setup as above.

Just to be clear, you have absolutely NOTHING else loaded? ACE, CBA? Anything else? Are you sure you don't have your UPPERCASE and lowercase letters confused and both X are the same?

testing with CBA and ACE....

Steve added a comment.Jan 4 2019, 2:39 PM
In T2878#40101, @Dusin wrote:

Short test from me - open Startis in editor, place unit, run mission and run "sideChat" from console at mission start, at time+70 and at time+200.

A) No mods; SP -- sidechat displayed 3 times
B) CUP Terrain Core, CUP Terrain Maps; SP -- sidechat displayed 3 times
C) No mods; MP -- sidechat is not displayed
D) CUP Terrain Core, CUP Terrain Maps; MP -- sidechat is not displayed

Dusin, thank you very much for your help! I also tried to do this on Chernarus in multiplayer and it worked! The problem was just in my lack of experience in making missions (I didn’t know how to use the console at all).
So now as it works, should I remove this topic or keep it alive for some other un-experienced players like me?

Steve added a comment.Jan 4 2019, 2:43 PM

DEV: Unable to reproduce on CUP Dev Branch using only "DEV CUP Terrains Complete". Setup was exactly as specified (BLUFOR - Present - this - X=True, X - player sideChat "message"), with the additional caveat of a 10mx10m area on Trigger 1

Live: Unable to reproduce on live using only Terrains Core and Maps. Same setup as above.

Just to be clear, you have absolutely NOTHING else loaded? ACE, CBA? Anything else? Are you sure you don't have your UPPERCASE and lowercase letters confused and both X are the same?

testing with CBA and ACE....

It’s very nice that you are trying to solve the problem, sir, but I tried Dusin’s solution and it worked for me. I am 100% sure that I wasn’t using any other mods.
So I think that the problem is absolutely solved and it was just about me, not the mod.
Thank you.

Derp

glad I could try anyways :)

NeoArmageddon closed this task as Invalid.Jan 4 2019, 2:51 PM
NeoArmageddon claimed this task.
NeoArmageddon triaged this task as None priority.