Conflict between Tanoa heads and some CUP uniforms
Closed, Invalid (BI Issue)Public

Description

When the player has any of those uniforms on and has a Tanoan head, the shadow of its arms will be glitched out. This was tested on dev cup.
Affected class names: Takistani Uniform Green and Mix, SLA uniforms all camo variants, Partisans uniforms all camo uniforms.
Pictures: https://imgur.com/a/JaJ3zyG
https://imgur.com/a/tdewFNY
https://imgur.com/a/HRv98iA
https://imgur.com/a/fN0otAD

Details

Commits
Restricted Diffusion Commit
Branch
Development
Reproducable without other mods?
Yes
Window created this task.Jan 12 2019, 3:03 AM
Window updated the task description. (Show Details)
Sparfell_19 triaged this task as Unbreak Now! priority.EditedSep 19 2019, 8:31 PM
Sparfell_19 changed the task status from Needs Review to Open.
Sparfell_19 added a subscriber: Sparfell_19.

These uniform models are no longer used in CUP.
But there seems to be a real issue when tanoa faces and some new CUP uniforms are combined :


New german uniform and new BDU

Sparfell_19 renamed this task from Shadow Lod on the Partisan, SLA, Takistani Uniform. to Conflict between Tanoa heads and some CUP uniforms.Sep 19 2019, 8:32 PM
Sparfell_19 added subscribers: Taro, AUTigerGrad.

Wasn't there a recent change that removed the head from the shadow LOD and added it to the head?
At least I seem to think that was intended to happen, but if it didn't it might be that the Tanoa heads have a faulty shadow volume

Not all uniforms are affected

Definitely all the German units. I don't know how many of our other units have a head proxy in the Shadow LOD. The new German uniforms have them, if this is true then there is nothing we can do. BIS needs to fix this.

Freddo3000 closed this task as Invalid (BI Issue).Tue, Mar 24, 6:36 AM
Freddo3000 claimed this task.

In all fairness, this was *not* a BI issue but an error in the uniform model that had some vertices assigned to the wrong selection

Freddo3000 added a comment.EditedTue, Mar 24, 8:03 AM

Fair enough, I've just heard about a lot of issues regarding Tanoa heads. Figured this was caused by that.

Taro added a commit: Restricted Diffusion Commit.Tue, Mar 24, 9:53 PM