[DEV] Magazine clipping (again)
Closed, ResolvedPublic

Description

Many of the STANAG-using weapons now experience magazine clipping issues after the magazine size increase
M16A2 used for demonstration. Almost all of the AR-15-type weapons (HK416s included, though 416s was mainly the front of the magazine well) and the SA80s experience some form of clipping to varying degrees due to imprecision with the magazine proxy system and its update rate. The SCARs do not appear to be affected, and I

Proposed solution 1: Slightly increase the size of the various AR-15s, 416s, and SA80s

Proposed solution 2: Slightly decrease the size of the various STANAG magazines

While this also affects the Mk12 SPR, it is substantially undersized and is covered in another ticket

Details

Branch
Development
Reproducable without other mods?
Yes
hvymtal created this task.Jan 15 2019, 5:20 PM

UPDATE: Tested in Arma 3 Dev Branch

Quote from me from Discord (15 Jan 2018 @ 19:30 GMT, 12:30 US MST/GMT-7)

Okay, testing on Arma 3 dev it seems the imprecision in mag proxies no longer seems to be a thing and clipping, if present, is not readily visible (mk12 excepted, but that's a special case) IDFK what is going on here, maybe they made some changes to the way mag proxies are handled on dev branch. Now all the clipping I was getting earlier simply isn't happening anymore. I Swear I'm not going crazy

Dusin assigned this task to hvymtal.Jan 16 2019, 11:14 AM
Dusin added a subscriber: Dusin.

As discussed with @hvymtal:

Issue caused by delay in proxy animation in respect to character/weapon animation (same for scopes, lasers and bipods). It is also affected by scene and PC performance, so in Virtual Arsenal with not bad PC (that i have) it is not reproducible. So all future proxy tests should be performed on heavy environment (city center of Altis towns, with big view distance and etc.) or with low-spec PC.

1.90 RC introduce mag proxy for vanilla weapons AND (looks like) removes proxy animation delays (for scopes and lasers too), so issue can not be reproduced on 1.90RC.

Mk16 mag size weren't changed, so if it clipping now - then it clipping all the time from last CUPdate, vanilla mags are clipping too, but it less noticible because of dark color.


As a backup plan i've scaled all mags 5% slimmer (pbo to test). @hvymtal, please, download and copy pbo to your \Arma 3\!Workshop\@[DEV] CUP Weapons\addons folder and check again.

You can use this script (execute in console) to automatically switch through 556 guns and mags while you in Camera view (you can also pause loop by camera's Acc Time slider):

gunlist = [
	"CUP_arifle_HK416_CQB_Black"	
	,"CUP_arifle_HK416_CQB_M203_Black"
	,"CUP_arifle_HK416_Black"	
	,"CUP_arifle_HK416_AGL_Black"	
	,"CUP_arifle_HK416_M203_Black"	
	,"CUP_arifle_L85A2"
	,"CUP_arifle_L85A2_G"
	,"CUP_arifle_L85A2_NG"
	,"CUP_arifle_L85A2_GL"
	,"CUP_arifle_L86A2"
	,"CUP_arifle_M16A2"
	,"CUP_arifle_M16A2_GL"
	,"CUP_arifle_M16A4_Base"
	,"CUP_arifle_M16A4_Grip"
	,"CUP_arifle_M16A4_GL"
	,"CUP_arifle_HK_M27"
	,"CUP_arifle_SBR_black"
	,"CUP_arifle_M4A1_black"
	,"CUP_arifle_M4A1"	
	,"CUP_arifle_M4A1_BUIS_GL"	
	,"CUP_arifle_M4A3_black"	
	,"CUP_arifle_mk18_black"
	,"CUP_arifle_mk18_m203_black"
	,"CUP_arifle_Mk16_CQC"	
	,"CUP_arifle_Mk16_CQC_FG"
	,"CUP_arifle_Mk16_CQC_SFG"	
	,"CUP_arifle_Mk16_CQC_EGLM"
	,"CUP_arifle_Mk16_STD"
	,"CUP_arifle_Mk16_STD_FG"
	,"CUP_arifle_Mk16_STD_SFG"
	,"CUP_arifle_Mk16_STD_EGLM"
	,"CUP_arifle_Mk16_SV"
];

maglist = [
	"CUP_30Rnd_556x45_Emag"
	,"CUP_30Rnd_556x45_Stanag_L85"
	,"CUP_30Rnd_556x45_Stanag"
	,"CUP_100Rnd_556x45_BetaCMag_ar15"
	,"CUP_30Rnd_556x45_Stanag_Mk16"
	,"CUP_30Rnd_556x45_Stanag_Mk16_black"
	,"CUP_30Rnd_556x45_Stanag_Mk16_woodland"
	,"CUP_60Rnd_556x45_SureFire"
	,"CUP_20Rnd_556x45_Stanag"
	,"CUP_30Rnd_556x45_PMAG_QP"
	,"30Rnd_556x45_Stanag"
];

A = true; // TO disable loop execute A = false
T1 = 1; T2 = 0.1; // Speed of loop, to change - execute T1 = 0.3;
[] spawn {
	{		
		removeAllWeapons player;		
		player addWeapon _x;
		
		{
			[primaryWeapon player, _x] call BIS_fnc_showSubtitle;
			player addPrimaryWeaponItem _x;
			
			if (!A) exitWith {};
			sleep T1;			
		} forEach maglist;
		
		if (!A) exitWith {};
		sleep T2;
	} forEach gunlist;	
};
Dusin triaged this task as Normal priority.Jan 21 2019, 2:56 PM
Dusin changed the task status from Needs Review to In Progress.

Made changes to magazines to remove parts that are permanently sticking out from some models (this should fix permanent clipping for AR15/HK416s).

"Floating" clipping should be fixed along with BIS mags compatibility for each 556x45 weapon ( reference model added - \Weapons\CUP_Weapons_Ammunition\magazines_proxy\Magwell_Compat_Placeholder_556STANAG.p3d - weapon magwell outer size should be at least same size as given model to avoid clipping of BIS/RHS mags)

Dusin added a comment.Jan 24 2019, 9:40 PM

Made a downscale for all 5.56 mags to ≤ 22.5 x 64.4 mm size.

Some testing is needed with this pbo: https://drive.google.com/open?id=10TNt_abXZK0XpvHftseRaw2V5pFzqrlI

Testing: magazine clipping reduced on most rifles. Side clipping now not noticeable, front clipping still present on some AR-15s

SA80 still experiences clipping. Needs enlargement of magazine well somewhat

HK416 experienced almost no clipping with prior iterations, did not test

SCAR never experienced any clipping whatsoever, did not test

Dusin claimed this task.Jan 29 2019, 11:50 AM
Dusin reassigned this task from Dusin to hvymtal.EditedJan 30 2019, 12:58 PM

Tested and got only flashing front clipping on some animations (e.g. player playMoveNow "AidlPknlMstpSlowWrflDnon_G01" )

Affected guns:

  • L85 (all)
  • HK416 (all, incl. IAR)
  • M16 (both A2 and A4 and GL variants)

@hvymtal , please confirm that there is no side clipping (flashing or permanent) when using https://drive.google.com/open?id=10TNt_abXZK0XpvHftseRaw2V5pFzqrlI (downsaceld mags).

p.s. Looks like sometimes for some reason magazine proxy may stop floating in displaced position (e.g. stick out from the front of magwell) - if happens to you, please provide screenshots.

UPD after discord discussion:
L85 has some side clipping too:

@hvymtal: Very minor and sporadic, may only need a fraction of a millimeter's adjustment to eliminate

Dusin closed this task as Resolved.Jan 31 2019, 2:26 PM
Dusin claimed this task.

Fixed for:

  • L85 (all variants) and L86
  • HK416 (all variants except of m203)
  • M16A2/A4/M203

M16A2/A4 with BIS STANAG still has side clipping, but assume it will be fixed once BIS fix their mags.