Some weapons aren't compatible with modded suppressors
Needs Review, Needs TriagePublic

Description

While some weapons like M4/M16, MK18 are compatible with other modded suppressors, some aren't :

  • M24
  • L155A3 LRR
  • All variants of CZ805
  • All M249
  • All minimi
  • All Scar L
  • All Scar H
  • L129a1
  • HK417
  • All FN FAL
  • All M14
  • M110
  • Glock 17
  • M9

Details

Branch
Development
Matth created this task.Thu, Feb 21, 1:01 PM
Matth renamed this task from CZ805 aren't compatible with modded suppressors to Some weapons aren't compatible with modded suppressors.Thu, Feb 21, 1:08 PM
Matth updated the task description. (Show Details)
Matth updated the task description. (Show Details)

T2952 fixed HK416 and HK417. I can take a look at some of the other weapons, at least the SCAR needs the same fix.

dahlgren updated the task description. (Show Details)Thu, Feb 21, 1:15 PM
dahlgren updated the task description. (Show Details)Thu, Feb 21, 2:52 PM

Could you please make suppressor of CUP M9 compatible with RHS M9?

Sure, I can make the M9 and its suppressor compatible with other mods

dahlgren updated the task description. (Show Details)Wed, Feb 27, 11:08 PM
Matth updated the task description. (Show Details)Thu, Mar 7, 4:35 PM
Matth updated the task description. (Show Details)