T-34 low damage
Closed, InvalidPublic

Description

Despite being a full sized 85mm round that should outright destroy most thinly armored vehicles it does very little damage against them. Examples include APCs or AAA like the Shilka, BMP, Tunguska, or Stryker surviving direct shots at point blank ranges.

Details

Affected classnames
CUP_Sh_3UBK9_HEAT
Branch
Release/Stable
Freddo3000 triaged this task as None priority.Jan 3 2020, 12:53 AM
Freddo3000 changed the task status from Needs Review to Cannot Reproduce.
Chairborne added a subscriber: Chairborne.EditedJan 18 2020, 3:57 PM

the gun uses a 100mm shell (as indicated in the classname - 3UBK9), not 85mm, also iirc there's a minimum travel distance required for the fuze to activate

Urban closed this task as Invalid.Sat, Jun 6, 2:39 PM
Urban claimed this task.
Urban added a subscriber: Urban.

Cannot Reproduce