HK416 PMAGs showing as double quantity in player HUD
Closed, ResolvedPublic

Description

When carrying certain HK416 rifles, certain PMAGs in the player's inventory are counted as double and displayed as such, showing the player to have more spare magazines than what are actually being carried. However, this is shown to happen differently depending on the rifle carried.

Testing thus far shows that when carrying the HK416 (Desert) or HK416 CQC (Desert) rifles, any additional PMAG (Tan) magazines in the player's inventory are counted as two magazines, and displayed as such within the HUD. The magazine inserted into the weapon does not contribute to the effect.


Additionally, when carrying the HK416 (Woodland) or HK416 CQC (Woodland) rifles, the same effect is noted with any additional PMAG (OD) magazines in the player's inventory.


This effect is thus far not seen with any HK416 rifle with a mounted grenade launcher, regardless of rifle color or magazine type.

To reproduce, load into a Virtual Arsenal and follow the steps accordingly:

  1. Equip any HK416 or HK416 CQC rifle of the Desert or Woodland variants that do not have a mounted grenade launcher.
  2. Remove any pre-added magazines from the player inventory, then add to inventory at least one 30Rnd 5.56mm PMAG of color matching that of the rifle (OD to match Woodland rifles, Tan to match Desert rifles.) The magazine inserted into the rifle will not contribute to the effect regardless of the rifle or inserted magazine's variant.
  3. For every one PMAG of color matching that of the rifle in the player's inventory, the HUD will display 2 magazines in the player's spare magazine count.

Details

Commits
Restricted Diffusion Commit
Branch
Development
Reproducable without other mods?
Yes
Yin_Yue_ created this task.Mar 31 2019, 6:55 PM
Yin_Yue_ updated the task description. (Show Details)Mar 31 2019, 6:59 PM
Dusin triaged this task as Unbreak Now! priority.EditedMar 31 2019, 9:09 PM
Dusin changed the task status from Needs Review to Acknowledged.
Dusin added a subscriber: Dusin.

Looks like this caused by magazines[] array that have duplicates.

Should be reproducible with Camo variants of G36 too

Dusin claimed this task.Mar 31 2019, 10:21 PM

Someone pick up the phone, he called it.

Dusin closed this task as Resolved by committing Restricted Diffusion Commit.Apr 1 2019, 1:29 PM
Dusin added a commit: Restricted Diffusion Commit.