M16A2 M203 carbine/M4A1/SA-58P/VSS incorrect weight
Closed, ResolvedPublic

Description

  • The M16A2 M203 carbine weighs exactly the same as the standard M16A2 M203, the standard black M4A1 weighs slightly less than the camouflaged M4A1s despite the camouflage being the only difference,
  • SA-58P weighs exactly the same as the SA-58V despite having a fixed stock compared to the SA-58V's collapsible stock,
  • VSS with the RIS mount and flashlight weighs exactly the same as all the other VSS variants (while the VSS with only the flashlight weighs more).

Details

Affected classnames
CUP_arifle_Colt727_M203, CUP_arifle_M4A1_black, CUP_arifle_Sa58P_des, CUP_arifle_Sa58P, CUP_srifle_VSSVintorez_flash_top
Branch
Release/Stable
Reproducable without other mods?
Yes
Goopy created this task.Apr 25 2019, 4:35 AM
Goopy renamed this task from M16A2 M203 carbine incorrect weight to M16A2 M203 carbine/M4A1 incorrect weight.Apr 25 2019, 4:45 AM
Goopy updated the task description. (Show Details)
Goopy changed Affected classnames from CUP_arifle_Colt727_M203 to CUP_arifle_Colt727_M203, CUP_arifle_M4A1_black.
Goopy renamed this task from M16A2 M203 carbine/M4A1 incorrect weight to M16A2 M203 carbine/M4A1/SA-58P incorrect weight.Apr 25 2019, 5:32 AM
Goopy updated the task description. (Show Details)
Goopy changed Affected classnames from CUP_arifle_Colt727_M203, CUP_arifle_M4A1_black to CUP_arifle_Colt727_M203, CUP_arifle_M4A1_black, CUP_arifle_Sa58P_des, CUP_arifle_Sa58P.
Dusin added a subscriber: Dusin.EditedApr 25 2019, 9:44 AM

@Goopy Please, move SA-58 to separate ticket and leave this one for M4/M16 only. Thanks in advance!

Goopy added a comment.EditedApr 25 2019, 9:45 AM

@Dusin I was told not to create anymore separate tickets for each weapon with this issue, so I added the SA-58 onto this ticket as a result.

Goopy renamed this task from M16A2 M203 carbine/M4A1/SA-58P incorrect weight to M16A2 M203 carbine/M4A1/SA-58P/VSS incorrect weight.Apr 25 2019, 10:32 AM
Goopy updated the task description. (Show Details)
Goopy changed Affected classnames from CUP_arifle_Colt727_M203, CUP_arifle_M4A1_black, CUP_arifle_Sa58P_des, CUP_arifle_Sa58P to CUP_arifle_Colt727_M203, CUP_arifle_M4A1_black, CUP_arifle_Sa58P_des, CUP_arifle_Sa58P, CUP_srifle_VSSVintorez_flash_top.
Dusin updated the task description. (Show Details)Sep 23 2019, 1:50 PM
Dusin triaged this task as Low priority.
Dusin changed the task status from Needs Review to Acknowledged.
Urban updated the task description. (Show Details)Oct 5 2019, 5:01 PM
Dusin closed this task as Resolved.Oct 10 2019, 5:17 PM
Dusin claimed this task.
SA-58P weighs exactly the same as the SA-58V despite having a fixed stock compared to the SA-58V's collapsible stock,

Fixed stock may wieght same or less than collapsible because of (a) less dense materials used (wood) and (b) absence of extra details (mounts, locks). There is no much info about weigh difference between these 2 models, so don't think we need change anything there.