Handgun suppressors clipping
Closed, ResolvedPublic

Description

a) M9 silencer clipping at every handgun except M9.
b) Vanilla 9mm silencer slightly clipping at Glock17 pistols

Expected:
a) center M9 silencer to avoid clipping
b) move muzzle proxy for Glock17 a bit forward

Original desciption:

The vanilla 9mm suppressor is for the 9x21 caliber cartridge, the listed weapons run a 9x19 caliber cartridge. This difference can bee seen visually on the weapons as the suppressor is too big and in some cases clips into the slide of the weapon. I beleive the affected weapons who currently have the vanilla suppressor as their only suppressor could have it switched to the already implemented CUP_muzzle_snds_M9 as a solution.

Details

Commits
Restricted Diffusion Commit
Affected classnames
CUP_hgun_Glock17, CUP_hgun_Glock17_blk, CUP_hgun_Glock17_tan, CUP_hgun_M9, CUP_hgun_Compact, CUP_hgun_Duty, CUP_hgun_Phantom
Branch
Development
Reproducable without other mods?
Yes
Goopy created this task.Apr 27 2019, 12:57 PM
Dusin renamed this task from Vanilla 9mm suppressor available for 9x19 caliber weapons to Handgun suppressors clipping.May 26 2019, 10:35 PM
Dusin changed the task status from Needs Review to Acknowledged.
Dusin triaged this task as Low priority.
Dusin updated the task description. (Show Details)
Dusin added a subscriber: Dusin.EditedMay 26 2019, 10:39 PM

21 in 9x21 means that cartridge is bigger (because of bullet or case). So 9x21 silencer can pass 9x19 bullets, can be installed to 9mm barrel. It may be some difference in efficiency, but whatever.

Updated ticket description.

Urban closed this task as Resolved by committing Restricted Diffusion Commit.Sep 26 2019, 8:25 PM
Urban added a commit: Restricted Diffusion Commit.