Bundeswehr missing the Wiesel AWC (the Nyx line of vehicles)
Closed, InvalidPublic

Description

The Nyx series of vehicles introduced in the Tanks DLC for the AAF are vehicles of German origin (called the Wiesel AWC) and are in current use by the Bundeswehr. Therefore it would seem that they could receive the same treatment that the Strider (Fennek) has, thereby adding three new combat vehicles to the Bundeswehr.

The Autocannon Nyx would be renamed to the Wiesel 1

The Scout Nyx would be renamed to the Wiesel 2 RFCV (Reconnaissance and Fire Control Vehicle)

The AA Nyx could be called the Ozelot Light Air Defence System or more simply the Ozelot

I left out the AT Nyx because the weapons system fitted onto it is completely fictional, the real life AT Wiesel uses the TOW with a combined MG3 coaxial rather than a M2.

Details

Affected classnames
I_LT_01_cannon_F, I_LT_01_AA_F, I_LT_01_scout_F
Branch
Development
Reproducable without other mods?
Yes
Goopy created this task.Wed, May 29, 10:30 PM
Chairborne closed this task as Invalid.Wed, May 29, 10:36 PM
Chairborne claimed this task.