Placing a comment in the 3D editor when CUP Terrains - MAPS is loaded forces a CUP dependency even on vanilla maps.
Closed, InvalidPublic

Description

Exactly as the title says. Simply loading up the 3D editor placing a comment down with nothing else on the map will force a CUP addon dependency, specifically "Desert", even on Altis/Stratis/Malden 2035 etc. I've confirmed it only happens when CUP Terrains - MAPS is loaded and loading CUP Terrains - Core is not necessary.

Here's the simplest possible test mission demonstrating this behavior. It only has a comment in it. Simply delete the comment and then save the mission and notice how the "Desert" addon is removed from the mission.sqm

Details

Branch
Release/Stable
Reproducable without other mods?
Yes
Cyprus created this task.Tue, Aug 6, 3:59 PM

I have observed the same issue with other addons, not only CUP Terrains. For example, Varanon's FHQ Debug Console has the same issue. I personally think it is not a problem of the addons but rather of the Eden comment node.

audiocustoms triaged this task as Normal priority.Tue, Aug 6, 4:27 PM
audiocustoms changed the task status from Needs Review to Acknowledged.

@Cyprus
I also think that might be an Eden / Comment issue since we do not have entries in "desert" that forces a dependency.
Ticked marked as "Acknowledged" for further inverstigation on a later date.

audiocustoms closed this task as Invalid.EditedTue, Aug 6, 4:40 PM
audiocustoms claimed this task.

After quick and intense research (talking to some dudes who know their stuff): Arma issue
Nothing we can do about it.

Workarounds when using comments:

  • don't use maps if not needed
  • open the SQM file in an editor and remove the "desert" entry in
addons[]=
{
	
};

(keep in mind, last entry must not end with a comma ,)

Cyprus added a comment.Tue, Aug 6, 7:20 PM

Yeah, thankfully it's easy to work around, it was just very frustrating having to deal with when editing any missions with comments such as the Escape missions from NeoArmageddon, which I spend a lot of time editing. It's nice not to have to constantly load and unload mods to avoid issues, so it's unfortunate it's not just an easy fix for you guys. I might test to see if this triggers with other mods, but so far I haven't been able to reproduce anything like it with any other mod except IFA3, but I'm still trying to pin that one down. Would submitting a ticket to Bohemia be worth it, or are they already aware of it?