F-35 erroneously low performance
Closed, WontfixPublic

Description

The F-35 is a supersonic jet fighter capable of reaching speeds up to 1900 km/h, yet in game it struggles to break mach one in a dive. While I don't expect it to be set at 1900 km/h (even aircraft like the vanilla blackwasp had a heavy reduction in realistic top speed for balance purposes) it should have a better acceleration than what it's at now.

I believe it has something to do with how the "envelope[]" values are set, which determines how the aircraft accelerates at different speeds.

Here's the Blackwasp's as an example.
envelope[] = {0,0.11,0.43,0.97,1.72,2.69,3.87,5.27,6.89,8.72,9.7,9.6,9.2,8.5,8.2,8};

And here's the F-35's, notice how it levels off back to 0 rather than down around 8 like the Blackwasp (which actually has a lower top speed set for it in it's configs when compared to the F-35 [1200 vs 1400].)
envelope[] = {0,0.4,1.9,4,6.8,8.3,8.5,8,7.2,5.8,4,1.8,0.5,0};

Details

Affected classnames
All F-35's
Branch
Development
Reproducable without other mods?
Yes
Goopy created this task.Oct 10 2019, 11:34 PM
Chairborne closed this task as Wontfix.Oct 10 2019, 11:48 PM
Chairborne claimed this task.
Chairborne added a subscriber: Chairborne.

engine issue, fix is too time intensive and causes other issues

Has an adjustment to the envelope values like I mentioned been tried before? Cause if it was an engine issue, wouldn't stuff like the Blackwasp or SU-34 not be able to reach higher top speeds that they're able to hit now?

top speed has nothing to do with the envelope array, and afaik the su34 is still capped like the f35

Goopy added a comment.Oct 11 2019, 1:07 AM

Hmmm, I wonder how BIS was able to get their aircraft to go supersonic then. Because even a straight copy of the Blackwasp/Shikra's performance characteristics would be better than how it is now.