Decolorization and Shadow issues for Uniforms
Closed, ResolvedPublic

Description

BDU's and German uniforms have issues with Discoloration of arms and legs, and German uniforms have shadow issues with heads. The following needs to be done with all uniforms:

  • Delete the head geometry on the Shadow lods
  • Delete the "bysta" proxy on shadow lods if present
  • make sure only fleshy parts are part of the "hl" selection

Details

Commits
Restricted Diffusion Commit
Branch
Release/Stable
Reproducable without other mods?
Yes
Alwarren created this task.Mar 9 2020, 4:24 PM
Alwarren changed the task status from Open to Acknowledged.
Alwarren triaged this task as Unbreak Now! priority.
Urban added a subscriber: Urban.Mar 9 2020, 4:30 PM

Need list what uniforms are affected.

Alwarren added a comment.EditedMar 9 2020, 4:33 PM
  • All BDU'S (see commit)
  • German CUP_Ger_Uniform.p3d and variants
  • \CUP\Creatures\People\Military\CUP_Creatures_People_Military_Chedaki\CUP_Ins_Uniform2.p3d
  • Firefighter

Those are the ones I have identified so far.
About the head geometry on Shadow lods, that is low priority and I will try to solve that with a o2script

Taro added a subscriber: Taro.Mar 9 2020, 6:49 PM

Fortunately it's just a mesh issue and caused by the "hl" vertex group that got assigned to the uniform parts when the weights got copied from the base body. The "hl" selection is responsible for changing the exposed skin texture to match the face.

Isn't that what I wrote in the description above?

Alwarren claimed this task.Mar 9 2020, 9:14 PM

Shadow issue is caused by setTextured selections in the shadow, most notably camo, injruries_* and hl. They must not be used in shadow, only deformation bones.

Taro added a commit: Restricted Diffusion Commit.Mar 13 2020, 8:06 AM
Alwarren closed this task as Resolved.Mar 13 2020, 6:04 PM