AT-5 and 9M14P Malyutka missiles fly off target when you are inside the veh
Closed, WontfixPublic

Description

The at-5 and 9m14p missiles will veer off target when you are inside the vehicle and use the command fire to get your gunner to fire the missile.

They appear to work fine when you are outside the veh and the veh is manned by AI and this only seems to occur when the player is inside the veh with the AI as his gunner and you give the Ctrl left mouse button command fire.

They player himself can fire and guide the missile just fine if he is the gunner with AI in the veh.

https://streamable.com/1wwtab

https://streamable.com/wislri

https://streamable.com/ygmw1q

Details

Affected classnames
bmp1 bmp2 bmp1P
Branch
Release/Stable
Reproducable without other mods?
Yes
Apollo created this task.Apr 15 2020, 4:24 PM
Chairborne closed this task as Invalid (BI Issue).Apr 15 2020, 4:46 PM
Chairborne claimed this task.
Chairborne added a subscriber: Chairborne.

normal ai behavior

I did a test where I put the Bmp-1 and 2 missles and launchers on the BMP-3 and command fired the gunner. the missles would not work and would veer off.

this addWeaponTurret ["CUP_Vmlauncher_AT5_single_veh",[0]]; 
this addMagazineTurret ["CUP_8Rnd_AT5_BMP2_M",[0]];
this addWeaponTurret ["CUP_Vmlauncher_AT3_veh",[0]]; 
this addMagazineTurret ["CUP_4Rnd_AT3_M",[0]];
this addWeaponTurret ["CUP_Vmlauncher_AT5_veh",[0]]; 
this addMagazineTurret ["CUP_5Rnd_AT5_BRDM2_M",[0]];

I then put the bmp-3 missle and launcher on the bmp-1 and 2 and command fired the missiles and the missiles would track fine.
I then tested the BRDM2 ATGM launcher and rocket which works fine for command fire on the BRDM2 ATGM on the BMP-3

this addWeaponTurret ["CUP_Vmlauncher_AT5_veh",[0]]; 
this addMagazineTurret ["CUP_5Rnd_AT5_BRDM2_M",[0]];

The missles would veer off.

This leads me to believe that something in the launcher and missle ammo of the AT5 and AT3 is not working correctly when a commander slot is present and the player in the veh as the BMP3 laucher and ammo will work fine with the player in the veh commanding the AI to fire.. ill try to do more testing later but I thats about as far as I have been able to narrow down the issue so far. I cant see anything amiss in the configs that stands out.

Kllrt reopened this task as Open.Jun 7 2020, 9:01 PM
Freddo3000 triaged this task as Normal priority.Jun 9 2020, 8:38 PM
Chairborne removed Chairborne as the assignee of this task.Jul 14 2020, 2:11 PM
Chairborne closed this task as Wontfix.

idk where the problem is, config entries are the same and base classes are the same as well, tried changing turret inheritances and it didnt fix it, im out of ideas and i cant be bothered spending any more time on this. if you find out what the issue is let us know.

The bmp3 missiles work when them and their launcher are installed in the problem vehs. best solution might be just to make a workaround that uses the bmp-3 missile as the main class and make the bmp-1 and 2 missiles and launcher take their inheritance from the bmp-3 launcher and missile and just change the damages and flight speeds for the subclasses of missles.

i tried that, still didnt work