The AK47 (including all the AK variants that fire the 7.62x39 ammunition) are EXTREMELY overpowered.
Closed, ResolvedPublic

Description

The following screenshots are the result of damage testing; the target wore a Carrier Rig (level 4 armor) in every test, and received only one shot directly to the torso. The damage done can be seen on the bottom right corner of each screenshot.

In this screenshot is the standard AKM from the Apex dlc. He received 23% damage.

In this screenshot is the CUP Weapons AKM. He received 44% damage.

To understand how ridiculous this is, the screenshot below is the CUP Weapons FAL which fires a 7.62x51 NATO. It dealt 37% damage-- that's 7% less than what the CUP Weapons AK's are doing.

In conclusion, they are clearly overpowered and must be balanced. I'd like to add that you should please review the damage that all your weapons are doing. Make sure that they match the standards of the Vanilla weapons damage according to their calibers, because these inconsistencies have been the cause of so much confusion.

EDIT: An additional thought. Please check the weight of all your weapons as well, as they are just as inconsistent between the vanilla weapons. For example, the vanilla AKM and the CUP Weapons AKM vary in weight by a huge margin.

Details

Commits
Restricted Diffusion Commit
Branch
Release/Stable
Reproducable without other mods?
Yes
Vallis created this task.Jun 28 2020, 5:19 PM
Vallis updated the task description. (Show Details)Jun 28 2020, 5:24 PM
Urban closed this task as Resolved by committing Restricted Diffusion Commit.Jun 28 2020, 5:33 PM
Urban added a commit: Restricted Diffusion Commit.