M113 accelerates too fast in water, handles too well in water.
Closed, WontfixPublic

Description

The M113 can go from 0Km/h to 20Km/h in three seconds from a complete stop while in water. Also handles better in water than on land, it's almost as agile as a jet ski. Included video.

Details

Branch
Release/Stable
Reproducable without other mods?
Yes
Freddo3000 changed the task status from Needs Review to Open.Sep 4 2020, 9:47 AM
Freddo3000 triaged this task as Normal priority.
Chairborne closed this task as Wontfix.Sep 4 2020, 1:59 PM
Chairborne claimed this task.
Chairborne added a subscriber: Chairborne.

its by design, all amphib vehicles go at 20kph in water, its probably the only instance in the mod where values are deliberately exaggerated