RPK and its variants have incorrect rate of fire
Closed, ResolvedPublic

Description

If you look at the rate o fire of the weapons, they have a fire rate of 750 rpm (rounds per minute), when they should have 600 rpm (AK receiver standard RoF). Some say that the 74 variant has 650 rpm, but I haven't seen any source that states it.

Can be seen in-game by looking at the top left card on ACE Arsenal (ACE loaded) and by testing (CUP only). To test it you can set a timer at 3 seconds and fire, at full auto, a 30 rounds magazine. It should stop firing at the exact 3 s mark, which would match the 600 rpm (the AK matches it exactly, the RPK doesn't). The counter-test, which certifies the incorrect rate of fire, is to repeat the original but with a timer set at 2,4 seconds, which matches the 750 rpm exactly.

Info sheets (non-official, no official found) used as sources for this post:

The error can be found on both Release and DEV branches.

Thank you for your attention and the mods!

Details

Commits
Restricted Diffusion Commit
Affected classnames
CUP_arifle_RPK74; CUP_arifle_RPK74_45; CUP_arifle_RPK74_45_top_rail; CUP_arifle_RPK74M; CUP_arifle_RPK74M_top_rail; CUP_arifle_RPK74M_railed; CUP_arifle_RPK74_top_rail.
Branch
Release/Stable
Reproducable without other mods?
Yes
BifeO created this task.Mon, Nov 9, 5:59 PM

Checking the configs it appears to be a display error, as the current time between shots is 0.1 seconds.

60 * (1 / 0.1) = 600 RPM

BifeO added a comment.EditedSun, Nov 15, 3:38 AM

Tested again, RPKs are definitely faster. Any idea what may cause this? I thought it was the config too, but now you've told me that it isn't.

Edit: Does it match the AKs configs, in every aspect? If they differ, where? That may lead to it.
Thank you for your response, btw

RPK is definitely faster, it looks like the player facing firemodes are Single and Manual instead of the expected Single and FullAuto. Manual and it's child classes are inheriting directly from Mode_FullAuto and don't have reloadTime changed.

Drofseh closed this task as Resolved by committing Restricted Diffusion Commit.Sun, Nov 15, 4:31 AM
Drofseh added a commit: Restricted Diffusion Commit.