US BDU uniform duplicates
Closed, ResolvedPublic

Description

all of the US BDU M81 variants (rolled high/low, dirty, gloves, etc) are duplicated in the arsenal. The duplicates are the base classes I think, they don't have flags on the right shoulder.

Details

Commits
Restricted Diffusion Commit
Affected classnames
CUP_U_B_BDUv2_dirty_base, CUP_U_B_BDUv2_gloves_base, CUP_U_B_BDUv2_gloves_dirty_base, CUP_U_B_BDUv2_roll2_base, CUP_U_B_BDUv2_roll2_dirty_base, CUP_U_B_BDUv2_roll2_gloves_base, CUP_U_B_BDUv2_roll2_gloves_dirty_base, CUP_U_B_BDUv2_roll_base, CUP_U_B_BDUv2_roll_dirty_base, CUP_U_B_BDUv2_roll_gloves_base, CUP_U_B_BDUv2_roll_gloves_dirty_base
Branch
Development
Reproducable without other mods?
Yes

Are you talking about the "BDU (M81)" variants that are near the top of the arsenal (when sorted alphabetically)? Those are meant to not have the flags just like the rest of the BDUs of various patterns., they are for scenario designers to use for various purposes, Guerrillas, or other factions for example.

The "US BDU (M81) variants are identical save for the flag patch, but those are intended for U.S. forces, mostly late cold war 80s, through to early 2000s. There's also "BDU Desert" and "BDU Tiger Stripe" as well in both the BDU section (flagless) and in the RACS section with Royal (Saharani flag patches.) So it's intended behaviour.

That is unless I'm misunderstanding?

No, there's duplicate uniforms named "US BDU (M81, #variant)", right next to each other. It's only the M81 ones tho, as far as I can see

I just checked again and see it now, not sure how I didn't notice it the first time. I don't see #variant next to the names though. On my end the doubles have identical names but do in fact lack the flag patch on the duplicates. I'm attaching a screenshot, only mod loaded on my side other than CUP is CWR3.

Yes, that's what I meant. #variant was just my shorthand for all the roll sleeves/dirt options. I believe it's a result of the base classes accidentally having scope=2;, they can probably be changed to scope=1; as long as the proper flag uniform classes have scope=2;. If that makes any sense.

Urban closed this task as Resolved by committing Restricted Diffusion Commit.Sep 4 2021, 9:14 PM
Urban added a commit: Restricted Diffusion Commit.