Vehicles with KPVT Weapon keybind issue
Open, Needs TriagePublic

Description

On all vehicles with the KPVT should be on the Weapons Group 1 keybind, however it's on the Weapons Group 2 keybind.

Current control configuration on multiple vehicles
Weapons Group 1: nothing
Weapons Group 2: KPVT and coax machine gun

Includes the BDRM, BTR-60, BTR-80, GAZ-3937 Vodnik KPVT, and Hilux/Hilux Armored BTR-60.

Details

Commits
Restricted Diffusion Commit
Branch
Development
Reproducable without other mods?
Yes
Cyprus created this task.Wed, Sep 8, 4:38 PM
Urban closed this task as Resolved by committing Restricted Diffusion Commit.Sun, Sep 19, 12:52 PM
Urban added a commit: Restricted Diffusion Commit.
Cyprus reopened this task as Open.EditedMon, Sep 20, 6:06 AM

Current fixes didn't resolve issue previous observed behavior is the same. The KPVT should be on Weapons Group 1 and the coax machine gun should be on Weapons Group 2.

I also noticed that the 14.5mm cannon isn't on the new dual feed for it's ammo. It has 1 HE ready with 1 in reserve rest are AP. By default it starts with AP selected and you have to reload the HE rounds through the action menu. Is that intended?

KPVT does not have dual feed, it's just a big machine gun, so having it on the same key as the coax is probably correct.

Even if it's not necessarily realistic, having the two types of ammo for the 14.5mm on dual feed would allow the AI to properly use it though, making it much more formidable against other armored vehicles and infantry rather than one or the other.

HE ammunition appears to have only been issued when the KPVT was used in an AA role, as in the ZPU.
Correct solution is to remove HE ammo from the BTR, BRDM, etc. As they should only be issued the AP ammo.
These vehicles can all still engage infantry with their PKM.