Elcan Specter OS 3D Version Add to Arsenal
Closed, InvalidPublic

Description

Please can you guys make the 3D variants of the ELCAN Specter OS 4x (and its variants), 3D variants of the ELCAN Specter DR 1-4x (and its variants) and the 3D variant of the SUSAT L9A1 accessible in the arsenal and able to be added to inventory as a standalone item. Currently, the 2D versions are the only ones available in arsenal and with a keybind can be switched to the 3D versions, which are in the CUP files. Please could you make the 3D variants of the scope accessible in arsenals and inventories as items in their own right, since they already exist as separate items, just not accessible.

In the same way the G36 Dual Optic Sights have standalone (3D) versions available (also switchable between 2D and 3D with keybind).

Classnames of accessible 2D scopes:

"CUP_optic_Elcan_reflex"
"CUP_optic_SUSAT"

Classnames of hidden 3D scopes:

"CUP_optic_Elcan_reflex_3D"
"CUP_optic_SUSAT_3D"

Details

Affected classnames
"CUP_optic_Elcan_reflex" "CUP_optic_SUSAT" "CUP_optic_Elcan_reflex_3D" "CUP_optic_SUSAT_3D"
Branch
Release/Stable
Reproducable without other mods?
Yes
sunbud created this task.Sep 23 2021, 6:27 AM
sunbud updated the task description. (Show Details)Sep 23 2021, 6:29 AM
Urban closed this task as Invalid.Sep 23 2021, 7:25 AM
Urban claimed this task.
Urban added a subscriber: Urban.

This will double optics count in arsenal, which will be more confusing. Use CBA Accessory Functions to switch beetwen 2D and 3D variants.