KA-50/KA-52 Vikhr missiles use SACLOS guidance, which is incorrect. They should be laser guided.
Closed, InvalidPublic

Description

Summary:
9M121 VIKHR missiles in real life are laser guided. CUP has them treated as SACLOS guided, which is why the missiles spin out when you try to shoot something--unless you are looking through the camera when you fire them.

Because of this bug, the laser on the KA-50 and KA-52 actually serves no purpose for the aircraft itself.

What I expect to happen:
Vikhr missiles should lock onto and track laser targets.

What actually happens:
Vikhr missiles follow where the targeting camera is pointed, and the missiles cannot be used at all outside of the targeting camera.

Details

Branch
Release/Stable
Reproducable without other mods?
Yes
Spades_Neil updated the task description. (Show Details)Jun 28 2022, 12:43 AM
Spades_Neil checked Reproducable without other mods?.Jun 28 2022, 12:46 AM
Spades_Neil renamed this task from KA-50/52 Vikhr missiles use SACLOS guidance, which is incorrect. They should be laser guided. to KA-50/KA-52 Vikhr missiles use SACLOS guidance, which is incorrect. They should be laser guided..
Drofseh closed this task as Invalid.Jun 29 2022, 1:19 AM
Drofseh triaged this task as None priority.
Drofseh claimed this task.
Drofseh added a subscriber: Drofseh.

The Vikhr is correctly simulated. It's a beam riding SACLOS missile, not capable of being directed with a laser designator like a maverick or laser guide bomb.

Spades_Neil added a comment.EditedJun 29 2022, 12:14 PM

I was about to argue that due to the way ArmA behaves, it would be more accurate from how it handles to make it laser guided even if it's not technically accurate, but then as I began doing research on the subject to prove my point, I just found more to the contrary. Apparently the vikhr's laser receiver faces the carrier aircraft which means it literally can't see what's in front of it. So yeah, you're correct.

Too bad there's not a way to use the missile without having to stare down the targeting camera until it reaches the target.

That's how it works in reality. Beam Rider missiles have their laser receiver in the rear and react to movement of the laser. It's basically like a TOW just with an "optical" cable. The idea of a single-seat gunship was quickly abandoned.